Gravatar for adouglas@itagroup.com

Question by AbbyDouglas801, Jun 20, 2018 8:03 PM

Coveo for Salesforce - Facet Not Displaying Results

I'm trying to setup a new facet and it's not showing any results even though the fields have data in them on a majority of the records. It's a multi-select picklist I have indicated this in the help text and on the facet settings. Am I missing something?

Gravatar for gminero@coveo.com

Comment by gminero, Jun 20, 2018 8:38 PM

there could be one last place, if you select the search page settings, there is a result list component, add the field to the fields to include

3 Replies
Gravatar for erocheleau@coveo.com

Answer by Etienne, Jun 20, 2018 8:41 PM

Which edition of Coveo are you running? Free or Pro/Enterprise?

If its the later, you need to make sure this field is "facetable" in the Coveo Admin UI under `Fields` find your field name and edit it to check [ X ] Facet

in the field options.

Gravatar for adouglas@itagroup.com

Comment by AbbyDouglas801, Jun 20, 2018 8:54 PM

I'm using the free version and the Result List has the [x] 'Automatically select fields to include'.

Gravatar for adouglas@itagroup.com

Comment by AbbyDouglas801, Jun 21, 2018 4:57 PM

I tried your fix and it still didn't work. The field shows without the picklist values populated on the edit page, but when I save it disappears.

Gravatar for erocheleau@coveo.com

Answer by Etienne, Jun 21, 2018 8:20 PM

Last thing I can think of, can you check that your field is searchable/indexed in Salesforce?

If you check the properties of your field on your object in salesforce, there is an option there.

Gravatar for gminero@coveo.com

Answer by gminero, Jun 24, 2018 1:21 AM

Basically, the referenced field, being from ContentDocument should have been named @SfLastpublishedversionFIELDNAME vs the traditional @SfFieldname used for other object fieldnames.

Gravatar for erocheleau@coveo.com

Comment by Etienne, Jun 25, 2018 12:48 PM

Ah yes, because it's a relational field.

Ask a question