Gravatar for saurabh.d.goyal@outlook.com

Question by saurabh.d.goyal@outlook.com, Aug 7, 2018 5:32 AM

Coveo for Sitecore default search page working on CM but not on CD

Hi All,

I have installed coveo for sitecore with trail license on SC 9.0.2, After Configure both CM and CD, My CM default Coveo search page is coming up and searching data, but in CD same page shown error "Oops! Something went wrong on the server.If the problem persists contact the administrator.". Also there is no error coming up in logs i tried logging in Debug mode as well..

I tried republish site, rebuilding index but nothing working.

Thanks

Saurabh Goyal

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Aug 7, 2018 8:55 AM

Have you followed the Coveo for Sitecore scaling guide to configure your CM and CD instances?

https://docs.coveo.com/en/661/coveo-for-sitecore-v4/coveo-for-sitecore-scaling-guide

Particularly the use of a Farm Name identical on all instances?

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, Aug 7, 2018 12:14 PM

Are you trying to access the CD page on your master or web database?

This error occurs when you try to access the page using the *master* database, but the *Coveo_master_index* is disabled.

The search page has no way to query the master index on the CD since it has been disable....

On Sitecore 9, by the role given to your instance

<index role:require="!ContentDelivery" id="Coveo_master_index" type="Coveo.SearchProvider.ProviderIndex, Coveo.SearchProvider" patch:before = "*[1]">

Before Sitecore 9, by the `SwitchMasterToWeb.Coveo.config` file.

<index id="Coveomasterindex">
   <patch:delete />
</index>

0 Reply
Ask a question