Gravatar for manohar.ra@gmail.com

Question by manohar.ra, Sep 4, 2018 2:07 PM

Language FallBack Items are not getting indexed even after index rebuild

We have multilingual solution running on Sitecore 8.1 Update 3 (Sitecore.NET 8.1 (rev. 160519)) , We have 3 languages enabled Ja , En , Chinese

we have language fallback enabled for the site and all the relevant items , Chinese and Japanese falls back to english and works as expected

It appears that fallback versions are not playing well with Coveo, i have enabled ItemLevel language fallback for all the items on the website ,when my context language is japanese I would expect the search results to show an english version of an item if the item does not have a japanese version , i do not get any results for the japanese as there no items in the index (the fallback is not indexed)

Basically Fallback items are not getting indexed unless there is a version in the context language

CES Version on premise : Coveo Enterprise Search 7.0

Coveo for Sitecore version : Coveo for Sitecore 81 3.0 (1312).zip

<index id="Coveo_master_index" type="Coveo.SearchProvider.ProviderIndex, Coveo.SearchProvider">
<param desc="p_Name">$(id)</param>
<configuration ref="coveo/defaultIndexConfiguration"/>
<locations hint="list:AddCrawler">
<crawler type="Sitecore.ContentSearch.SitecoreItemCrawler, Sitecore.ContentSearch">
<Database>master</Database>
<Root>/sitecore</Root>
<StopOnError>true</StopOnError>
</crawler>
</locations>
<strategies hint="list:AddStrategy">
<strategy type="Sitecore.ContentSearch.Maintenance.Strategies.SynchronousStrategy, Sitecore.ContentSearch">
<param desc="database">master</param>
</strategy>
</strategies>
<propertyStore type="Sitecore.ContentSearch.Maintenance.IndexDatabasePropertyStore, Sitecore.ContentSearch">
<Key>$(id)</Key>
<Database>core</Database>
</propertyStore>
<SourceName patch:source="XXX.Coveo.Overrides.config">Coveo_master_index - DEVELOPER</SourceName>
<enableItemLanguageFallback patch:source="XXX.Coveo.Overrides.config">true</enableItemLanguageFallback>
<enableFieldLanguageFallback patch:source="XXX.Coveo.Overrides.config">true</enableFieldLanguageFallback>
</index>
<index id="Coveo_web_index" type="Coveo.SearchProvider.ProviderIndex, Coveo.SearchProvider">
<param desc="p_Name">$(id)</param>
<configuration ref="coveo/defaultIndexConfiguration"/>
<locations hint="list:AddCrawler">
<crawler type="Sitecore.ContentSearch.SitecoreItemCrawler, Sitecore.ContentSearch">
<Database>web</Database>
<Root>/sitecore</Root>
<StopOnError>true</StopOnError>
</crawler>
</locations>
<strategies hint="list:AddStrategy">
<strategy type="Sitecore.ContentSearch.Maintenance.Strategies.OnPublishEndAsynchronousStrategy, Sitecore.ContentSearch">
<param desc="database">web</param>
<CheckForThreshold>true</CheckForThreshold>
</strategy>
</strategies>
<propertyStore type="Sitecore.ContentSearch.Maintenance.IndexDatabasePropertyStore, Sitecore.ContentSearch">
<Key>$(id)</Key>
<Database>core</Database>
</propertyStore>
<SourceName patch:source="XXX.Coveo.Overrides.config">Coveo_web_index - DEVELOPER</SourceName>
<enableItemLanguageFallback patch:source="XXX.Coveo.Overrides.config">true</enableItemLanguageFallback>
<enableFieldLanguageFallback patch:source="XXX.Coveo.Overrides.config">true</enableFieldLanguageFallback>
</index>
1 Reply
Gravatar for hsantos@coveo.com

Answer by Hugo Santos, Sep 4, 2018 5:30 PM

Did you try the solution here https://docs.coveo.com/en/745/coveo-for-sitecore-v4/items-in-different-languages-are-not-automatically-indexed-or-updated-when-language-fallback-is-enabled?

Gravatar for manohar.ra@gmail.com

Comment by manohar.ra, Sep 5, 2018 11:59 AM

@Hugo Santos Thanks for the reply

We have raised a support case with Sitecore regarding this , would like to know more on how language fallback works

My assumption is that , if i have two languages configured on sitecore , for an item with language fallback enabled , i assume coveo should have 2 entries in the index one for each language ?

Ask a question