Gravatar for arif.solkar@kpittechnologieslimited.onmicrosoft.com

Question by Arif, Sep 10, 2018 10:39 AM

Bad IL range error on coveo integration

Hi,

I am facing the following error on the sitecore. I have integrated coveo 4.1 on sitecore 9.

Below is the screenshot of the error.

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, Sep 10, 2018 12:45 PM

We really don't have enough information to properly help you. Can you give us more context about your error?

What were you doing? Did you install some .NET framework update? Upgraded Coveo for Sitecore?

Is this a new Sitecore instance? A new Coveo for Sitecore installation?

Did you check the Sitecore logs? Any event log that would help us?

What have you tried to fix this?

----

Looking at this error on the internet, it looks like you have corrupted assemblies.

Have you tried reinstalling the Coveo for Sitecore package? Or just copying back the DLLs?

1 Reply
Gravatar for flguillemette@coveo.com

Answer by François Lachance-Guillemette, Sep 11, 2018 3:04 PM

The error comes from your .NET environment and is not triggered by Coveo for Sitecore. In fact, I suspect none of the Coveo for Sitecore code is executed since it is a very generic error thrown by .NET.

Something is corrupted on your side, and I'm afraid there is not must we can do on our side to help you.

You will need to check your environment to validate what was recently installed at the time of the crash, see whether some files are missing or corrupted.

You could try disabling the Coveo for Sitecore configuration files to see if only Coveo assemblies are affected.

And as I previously suggested, try reinstalling the package to see if it solves the issue.

Ask a question