Gravatar for kiranb@techaspect.com

Question by Kiran Boreddy, Jan 24, 2019 4:22 PM

Last rebuild failed - source refresh timeout

Hi,

We are getting this error when we tried to reindex our prod instance. We are using Coveo for Sitecore version: 4.1.414.9, Sitecore version: 8.2.160729. For now, we only need to re-index a section of content tree. I reviewed https://docs.coveo.com/en/541/coveo-for-sitecore-v4/rebuilding-a-search-index Re-Indexing Only a Section of Your Content Tree Manually, is this approach suggested for a prod CD instance. Is this resource consuming process? I am asking this because our dev server was down when I tried this approach (I am not completely sure whether this caused the issue though).

Thanks,

Kiran

Gravatar for hsantos@coveo.com

Comment by Hugo Santos, Jan 24, 2019 4:25 PM

What exactly is the error on your log files?

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jan 24, 2019 4:45 PM

  1. Sitecore content delivery instances should never index items in Coveo. They should have the `SwitchMasterToWeb.Coveo.config` file enabled. This file patch deletes the strategies of the Coveo indices in Sitecore.
  2. For production problems like this, it is recommended to open a ticket to Coveo Support. This Q&A website is not for troubleshooting production issues. It is more suited for development questions.
1 Reply
Gravatar for hsantos@coveo.com

Answer by Hugo Santos, Jan 24, 2019 4:42 PM

It really depends, we need to see your log to be more precise.

But if I had to guess, I'd say that there is one or more Sitecore item which can't be processed on the Coveo Cloud Platform during the rebuild.

And since the Sitecore rebuild makes sure that every single indexed item is searchable at the end of its execution, and wait for 1 hour of inactivity on the Cloud Platform to really fail, that could be causing your timeout.

But again, that's just a blind guess.

Grab those log files and we will be more in a position to help you.

Ask a question