Gravatar for

Question by jpalbuja, Apr 16, 2019 6:59 PM

Unable to Activate Coveo for Sitecore 82

Hi guys, I am trying to activate Coveo for Sitecore 82 5.0.301.4 to my local Sitecore.NET 8.2 (rev. 161115). When I click on the "Activate" button I am getting the message "Activation failed: SyntaxError: Unexpected token < in JSON at position 0".

I saw in my browser console that the call to the end point "/coveo/api/config/v1/configure" is returning a 500 Internal Server Error and the response looks like this :

"<title>IIS 10.0 Detailed Error - 500.21 - Internal Server Error</title>"

"<div> <h3>HTTP Error 500.21 - Internal Server Error</h3> <h4>Handler "WebDAV" has a bad module "WebDAVModule" in its module list</h4> </div> <div> <fieldset><h4>Most likely causes:</h4> <ul> <li>Managed handler is used; however, ASP.NET is not installed or is not installed completely.</li> <li>There is a typographical error in the configuration for the handler module list.</li> <li>During application initialization, either the application initialization feature has set skipManagedModules to true, or a rewrite rule is setting a URL that maps to a managed handler and is also setting SKIP_MANAGED_MODULES=1.</li> </ul> </fieldset> </div> <div> <fieldset><h4>Things you can try:</h4> <ul> <li>Install ASP.NET if you are using managed handler.</li> <li>Ensure that the handler module's name is specified correctly. Module names are case-sensitive and use the format modules="StaticFileModule,DefaultDocumentModule,DirectoryListingModule".</li> <li>Ensure that any application initialization rewrite rules set SKIP_MANAGED_MODULE=0 when setting a URL that maps to a managed handler (such as .aspx, for example.)</li> <li>As an alternative, ensure that application initialization rewrite rules map the request to an unmanaged handler (for example, to an .htm file, which is mapped to the StaticFileHandler.)</li> </ul> </fieldset> </div>"

Could you please advise? Thanks

1 Reply
Gravatar for

Answer by jpalbuja, Apr 22, 2019 7:35 PM

Ask a question