Gravatar for

Question by sohel, Oct 13, 2014 2:49 PM

The field name translator must implement the interface "Coveo.Framework.Fields.IFieldNameTranslator".

Is the error I see when I try to insert a Coveo Search Page from Page Editor after successfully installing Coveo Interfaces package for Sitecore. Any idea where I should be looking?

More error details:

    Line 8:      script type="text/javascript">
Line 9:          Coveo.$(function() {
Line 10:             CoveoForSitecore.componentsOptions = <%= Model.GetJavaScriptInitializationOptions() %>;
Line 11:         });
Line 12:     script>

[InvalidOperationException: The field name translator must implement the interface "Coveo.Framework.Fields.IFieldNameTranslator".]

Coveo.UI.Helpers.SitecoreHelper.GetFieldNameTranslator(ISearchIndex pIndex) +288 Coveo.UI.Helpers.FieldHelper.ToCoveoFieldName(IIndexable pIndexable, String pSitecoreField, Boolean pUsePrefix) +264 Coveo.UI.Mvc.Models.SearchModelOptionsWriter.GetObjectToSerialize(ISearchModel pInstance) +209 Coveo.UI.Mvc.Models.BaseJavaScriptWriter`1.GetJavaScriptObject(T pInstance) +188

1 Reply
Gravatar for

Answer by Vincent Séguin, Oct 14, 2014 7:39 AM


Did you disable the Lucene indexes? You need to disable every config file that starts with Sitecore.ContentSearch.Lucene.*.

Do NOT disable the Sitecore.ContentSearch.config file though.

Let me know how it goes!

Gravatar for

Comment by sohel, Oct 14, 2014 10:51 AM

Hi Vincent, wont that disable Sitecore Content Search? Unless you think I should let Coveo to takeover as the search provider for both sitecore (ex: bucket search) and website (site search).

Is there a way I can keep Lucene as the standard search provider for Sitecore and use coveo for site search? Earlier before upgrading to sitecore 7 that is how I was using.

Gravatar for

Comment by Vincent Séguin, Oct 14, 2014 10:54 AM


The Search Provider is made to replace Lucene as the Sitecore search as well. It will behave exactly the same way, just that it will use Coveo underneath.

Currently there's no way you can have both in the same time unfortunately.

Gravatar for

Comment by sohel, Oct 14, 2014 11:01 AM

Thanks I had a different impression.

Ask a question