Gravatar for jschjolberg@awareweb.com

Question by jschjolberg, Oct 27, 2014 4:05 PM

What is causing invalid security providers?

We're using Coveo for Sitecore. I'm trying to understand how security providers are created in the Coveo Administration Tool. It appears that these are created automatically when you initially build an index from Sitecore and the name is based on the InstaneName setting in the site's Web.config. My first question is, is this the case?

My next question is around problems that occur when there is an invalid security provider. Right now, when I try to build my index from Sitecore, the index is not building. I notice that there is this WARNING in the system log (I changed the security provider name in the example below - replacing the site name with "SitecoreSiteName"):

WARNING 03:42:30 PM The security provider "Sitecore Security Provider for PUBLIC-CD-SitecoreSiteName" has encountered an exception: class Merlin::SecurityProviderNotRegisteredException: Security Provider "Sitecore Security Provider for PUBLIC-CD-SitecoreSiteName" not registered.

I don't see this security provider listed in the list of security providers in the Coveo admin. I'm trying to figure out why warning this is showing up. And could it be the cause of why the index isn't building?

3 Replies
Gravatar for vseguin@coveo.com

Answer by Vincent Séguin, Oct 27, 2014 4:08 PM

Hi,

It's simply because you never rebuilt/reindex an index. The security provider is not created yet. The first time you'll reindex or rebuild, it will create it and this warning will disappear.

Now, you could check in the Sitecore logs why the index is not building.

Thank you

Gravatar for slangevin@coveo.com

Answer by Simon, Oct 27, 2014 4:10 PM

Hi,

Did you replace the name in the Coveo.SearchProvider.config? Depending on your build, you might have to delete the current Security Providers and User Identity already existing in the Administration Tool before rebuilding with the corrected values.

And to answer your second question, yes, this is the reason why your indexing has stopped.

Cheers, Simon

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Dec 1, 2014 1:57 PM

We're having a similar issue, but the invalid SPs are from our CD servers and they no longer exist. When we first set up the CD servers, we hadn't removed the master/core indexes nor the strategies section of the web index. We have removed those since then, but Coveo is still getting errors for the SPs from the CD servers. Is there a way to purge these somewhere in Coveo? I've removed both them, the user identities, and the sources that were created from the CD servers.

Cris Corra

Gravatar for slangevin@coveo.com

Comment by Simon, Dec 1, 2014 2:16 PM

Hi Cris,

I think that's what you meant by "I've removed both them, the user identities, and the sources that were created from the CD servers." but I want to validate that what you mean. You deleted the Security providers, User identities and sources in the Coveo Administration Tool?

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Dec 1, 2014 4:19 PM

Yes, exactly. And we updated the Coveo.SearchProvider.config indexes section on the CD servers, so that only the web index remains and its Strategies section was removed.

Gravatar for slangevin@coveo.com

Comment by Simon, Dec 2, 2014 10:35 AM

Hi Cris, in newer versions, a node was added to the Search Provider config file:

This will allow you to specify the Security Provider to be queried. In July's version, the node is not present but the parameter was coded in the back-end, so you can add it manually in the defaultIndexConfiguration section. I added it right after the EncryptDataOnQueue node.

Hope it helps.

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Dec 2, 2014 4:27 PM

Thanks Simon but we already have this setting and have it set correctly. I'm going to open a support ticket for this issue.

Gravatar for slangevin@coveo.com

Comment by Simon, Jul 20, 2015 12:03 PM

This issue was troubleshooted by Coveo support and it appears that something was holding the security provider in a loop. Using Coveo CGLDump to clear the memory of the process solved the issue. The root cause is unfortunately unknown.

Gravatar for svivero@gmail.com

Answer by svivero, Jan 22, 2015 6:27 PM

Hi,

Had this issue when adding new instances in Azure. Coveo stopped creating new security providers for the new instances. I resolved this issue by deleting old security providers (no longer used) via Admin. Is there a limitation on how many security providers can be created?

fyi, sitecore for coveo 72.3.0 (free)

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Jan 23, 2015 7:26 AM

Hi,

There is no limitation on how many security providers can be created.

Ask a question