Gravatar for deepak.raghav87@gmail.com

Question by deepak_raghav, Oct 30, 2014 8:56 AM

CES 7.0 64x is not installing properly and rolling back saying interrupted

The CES 7.0 64x is not installing properly and Rolling back showing error like

2014-10-30 16:30:40,981 [1] INFO Coveo.CES.AdminService.AdminWindowsService [(null)] - Starting service. 2014-10-30 16:31:15,789 [4] ERROR Coveo.CES.AdminService.AdminServiceHost [(null)] - An exception occured when trying to retrieve the host name from AWS. System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 169.254.169.254:80 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetResponse() at Coveo.CES.AdminService.AdminServiceUtil.ObtainAwsPrivateHostName() at Coveo.CES.AdminService.AdminServiceHost.StartService() 2014-10-30 16:31:15,811 [4] DEBUG Coveo.CES.AdminService.Security.AdminServiceSecurityHandler [(null)] - Loading the security configuration file from path C:\Program Files\Coveo Enterprise Search 7\Bin\Coveo.CES.AdminService.Security.config 2014-10-30 16:31:15,831 [4] DEBUG Coveo.CES.AdminService.Security.SecurityConfigLoader [(null)] - No security config file available. Securities are disabled. 2014-10-30 16:31:15,831 [4] DEBUG Coveo.CES.AdminService.Security.AdminServiceSecurityHandler [(null)] - Security is disabled. 2014-10-30 16:31:15,859 [4] INFO Coveo.CES.AdminService.AdminService [(null)] - File 'C:\Coveo\AdminService\BuildFingerprint.txt' doesn't exist. Could not get the build number. 2014-10-30 16:31:34,854 [1] INFO Coveo.CES.AdminService.AdminWindowsService [(null)] - Service stopped.

Please let me know what can be done to m ake it work.

1 Reply
Gravatar for slangevin@coveo.com

Answer by Simon, Oct 30, 2014 9:56 AM

Hi,

The Admin Service is used mainly by Coveo cloud index: http://www.coveo.com/en/solutions/customer-service
It is also used with Coveo for Sitecore but since your on-premise instance is not on an Amazon VM, the ping will fail. This error is only noise however and is present on every on-premise install of the Admin Service and should not affect the installation.

I would advise to go through support for your installation issue: https://coveocommunity.force.com/customers/

Cheers, Simon

Ask a question