Gravatar for jesse.a.kearns@gmail.com

Question by jkearns, Oct 30, 2014 6:41 PM

Coveo Search Web Service: Access Is Denied

I am getting this error on the diagnostics page: "Coveo Search Web Service: Access Is Denied"

I am trying to configure Coveo where the sitecore instance is on a separate server from CES. I changed all the paths in Coveo.SearchProvider.config to this server's path, and when I did a new license was automatically created on the CES server, which I take to mean that the servers are communicating.

We suspect that the issue has to do with SSL on the CES server. The https path in the node in Coveo.SearchProvider.config, when opened in a browser, generates a warning about the website's security certificate. Would this by itself cause the problem we are seeing? Can you confirm that this is a problem with the server, and not a problem with our config files or Coveo?

Thanks

1 Reply
Gravatar for vseguin@coveo.com

Answer by Vincent Séguin, Oct 31, 2014 7:36 AM

Hi,

Normally, the Search Service path is in HTTPS, looking like https://localhost:52810/7.0/CoveoSearchService. Have you followed the steps described here ?:

https://developers.coveo.com/display/SC201410/Setting+Up+Coveo+for+Sitecore+in+a+Remote+Server+Configuration

Did you copy the certificates file to your Sitecore instance?

Gravatar for slangevin@coveo.com

Comment by Simon, Oct 31, 2014 9:17 AM

I agree with Vincent here. I have seen this issue before and it is always caused by the certificates not being copied.

Gravatar for jesse.a.kearns@gmail.com

Comment by jkearns, Oct 31, 2014 11:47 AM

Copying the certificates file to the Sitecore instance solved that problem. Thanks.

Ask a question