Gravatar for jrappel@parse3.com

Question by jrappel, Oct 31, 2014 1:07 PM

Configuring Database Source to Sql

Hello,

I have a collection with 2 sources. One points to our sitecore instance and works great. The other points to a custom database, and has problems connecting.

The Sql database is located on a different server, and I've verified that I can connect to the remote server from the Coveo server where indexing occurs, using the same credentials as are configured in the data source.

I'm receiving the following error on each run:

Unable to execute query with connection string : ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

The config file is using the ODBC template seeing as this is the only example I was able to find -> http://onlinehelp.coveo.com/en/CES/7.0/Administrator/ExampleofaConfigurationFilefortheDatabaseConnector.htm

My current settings are as follows: http://screencast.com/t/hEWcHyN7Ss

I've tried toggling the "Use 32 bits driver" to no avail. I see there are other options for Driver Type, including Sql Client.

Has anyone had experience with this?

Thanks,

John

2 Replies
Gravatar for jrappel@parse3.com

Answer by jrappel, Oct 31, 2014 1:23 PM

Final post:

This error indicated that no user was defined in the config file to access the Uri. I added:

AllowedUsers> AllowedUser type="Windows" allowed="true"> Name>everyone/Name> Server>/Server> /AllowedUser> /AllowedUsers>

To the Mapping in the config file and it worked as expected.

Hopefully this thread helps someone in the future.

-John

Gravatar for jrappel@parse3.com

Answer by jrappel, Oct 31, 2014 1:16 PM

Apologies for spam, but I continued troubleshooting. I changed the Driver Type to Sql Client, and then replaced in the config file with .

It's not reaching the database, but giving me an error on either the Uri field or ClickableUri field (I can't tell):

http://screencast.com/t/qc5sgnGLha

I have test data in the table for the time being. One of the results that fails is http://google.com. I assumed the Uri didn't matter. The instructions indicate that as long as it's unique, it's fine. There is only one record in my database at this time.

Gravatar for cbolduc@coveo.com

Comment by Carl Bolduc, Oct 31, 2014 1:25 PM

I just wanted to mention that you can edit your original question if needed.

Ask a question