Gravatar for nicolas.a.slavik@accenture.com

Question by yonico, Jan 15, 2015 4:35 PM

RabbitMQ failed after uncommenting

Hello - I made a change in Coveo.SearchProvider.config for using tag. I made a rollback of this and still having issues with RabbitMQ. The diagnostic page says: RabbitMQ None of the specified endpoints were reachable

Show this message when trying to index:

Job started: IndexUpdateIndexName=sitecoremasterindex|#Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> RabbitMQ.Client.Exceptions.BrokerUnreachableException: None of the specified endpoints were reachable ---> RabbitMQ.Client.Exceptions.PossibleAuthenticationFailureException: Possibly caused by authentication failure ---> RabbitMQ.Client.Exceptions.OperationInterruptedException: The AMQP operation was interrupted: AMQP close-reason, initiated by Library, code=541, text="Unexpected Exception", classId=0, methodId=0, cause=System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   --- End of inner exception stack trace ---
   at RabbitMQ.Client.Impl.Frame.ReadFrom(NetworkBinaryReader reader)
   at RabbitMQ.Client.Impl.SocketFrameHandler09.ReadFrame()
   at RabbitMQ.Client.Impl.ConnectionBase.MainLoopIteration()
   at RabbitMQ.Client.Impl.ConnectionBase.MainLoop()
   at RabbitMQ.Client.Impl.SimpleBlockingRpcContinuation.GetReply()
   at RabbitMQ.Client.Impl.ModelBase.ConnectionStartOk(IDictionary clientProperties, String mechanism, Byte[] response, String locale)
   at RabbitMQ.Client.Impl.ConnectionBase.StartAndTune()
   --- End of inner exception stack trace ---
   at RabbitMQ.Client.Impl.ConnectionBase.StartAndTune()
   at RabbitMQ.Client.Framing.Impl.v091.Connection.Open(Boolean insist)
   at RabbitMQ.Client.Impl.ConnectionBase..ctor(ConnectionFactory factory, Boolean insist, IFrameHandler frameHandler)
   at RabbitMQ.Client.Framing.Impl.v091.ProtocolBase.CreateConnection(ConnectionFactory factory, Boolean insist, IFrameHandler frameHandler)
   at RabbitMQ.Client.ConnectionFactory.FollowRedirectChain(Int32 maxRedirects, IDictionary connectionAttempts, IDictionary connectionErrors, AmqpTcpEndpoint[]& mostRecentKnownHosts, AmqpTcpEndpoint endpoint)
   --- End of inner exception stack trace ---
   at RabbitMQ.Client.ConnectionFactory.CreateConnection(Int32 maxRedirects)
   at Coveo.AbstractLayer.Communication.Queue.RabbitMqConnectionFactory.CreateConnection()
   at Coveo.AbstractLayer.Communication.Queue.RabbitMqCommunication.Connect()
   at Coveo.AbstractLayer.Communication.Queue.QueueCommunication.Connect()
   at Coveo.AbstractLayer.Communication.CES.CESCommunication.Initialize()
   at Coveo.SearchProvider.AbstractProviderUpdateContext..ctor(ISearchIndexSummary pIndexSummary, ICESCommunication pCommunication)
   at Coveo.SearchProvider.ProviderUpdateContext..ctor(ISearchIndex pIndex, ICESCommunication pCommunication)
   at Coveo.SearchProvider.ProviderIndex.CreateUpdateContext()
   at Coveo.SearchProvider.ProviderIndex.b__39()
   at Coveo.SearchProvider.ProviderIndex.Rebuild()
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
   at (Object , Object[] )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Jobs.Job.ThreadEntry(Object state)

I didnt touch any other tags and dont know why still failing. Any ideas?

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Jan 15, 2015 4:38 PM

Hello,

Is the RabbitMQ for Coveo service up and running? Can you try to restart it?

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Jan 16, 2015 9:24 AM

You can follow this procedure to verify your connection settings and modify them if needed: https://developers.coveo.com/display/SC201501/Configuring+the+Coveo+for+Sitecore+Indexing+Queue+Connection

Gravatar for nicolas.a.slavik@accenture.com

Comment by yonico, Jan 16, 2015 10:01 AM

That seems to work. Thanks for the assistance.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jan 16, 2015 10:47 AM

Please accept this answer if it resolves your issue. Thank you.

Gravatar for vermas.viet07@gmail.com

Comment by verma, Jul 12, 2018 9:32 AM

Ask a question