Gravatar for thomas.n.lin@avanade.com

Question by tohams, Mar 1, 2015 9:59 PM

An index should be configured for database "web"

I'm getting an error when browsing to http://mysite/coveo/rest. This is a Sitecore 7.5 site. Anyone have any ideas?

Thanks!

Server Error in '/' Application.

An index should be configured for database "web".

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: An index should be configured for database "web".

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[InvalidOperationException: An index should be configured for database "web".] Coveo.UI.Helpers.SitecoreHelper.GetSearchIndex() +332 Coveo.SearchProvider.Rest.SitecoreRestHttpHandler.GetSecurityProviderName() +70 Coveo.SearchProvider.Rest.SitecoreRestHttpHandler.OnInitializeSettings() +365 Coveo.Search.Api.Proxy.ProxyHttpHandler.OnInitialize() +58 Coveo.Search.Api.Proxy.ProxyHttpHandler.EnsureInitialized() +140 Coveo.Search.Api.Proxy.ProxyHttpHandler.ProcessRequest(HttpContext context) +78 System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34237

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Mar 2, 2015 8:58 AM

I think you forgot to activate the Coveo.SearchProvider.config file by removing the .example file extension after installing Coveo for Sitecore.

or

You upgraded to the February 2015 release and forgot to do the manual steps described in the upgrade documentation (see Upgrading Coveo for Sitecore)

Gravatar for slangevin@coveo.com

Comment by Simon, Mar 3, 2015 12:09 PM

I confirmed the issue today. If you upgrade without adding the correct declarations in the Search Provider config, it will return that error. So follow the guide!

https://developers.coveo.com/display/public/SC201502/Upgrading+Coveo+for+Sitecore

Ask a question