Gravatar for mohammad.chowdhury@us.tel.com

Question by mjc, Apr 7, 2015 11:46 AM

HttpException (0x80004005): Request timed out

From this morning getting "request timed out" exception!!!

Server Error in '/' Application.

Request timed out. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Request timed out.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[HttpException (0x80004005): Request timed out.]

I have changed readOperationTimeout=120 to 300, still getting the same exception.

Pleas help, Mohammad

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Apr 7, 2015 11:55 AM

Do you have more information about which request timeouts?

Which Coveo product are you using?

Gravatar for mohammad.chowdhury@us.tel.com

Comment by mjc, Apr 7, 2015 12:00 PM

That was all about the exception.

I am using 7.0 x64 Build 6830.0

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Apr 7, 2015 4:10 PM

More questions:

  • Which URL are you trying to access when you get this error?
  • Do you use Coveo for Sitecore?
  • Do you use Coveo .Net Front-End?
  • Do you use Coveo JavaScript Search Framework?
  • Your error description indicates that there was a stack trace on the error page. Can you give us this stacktrace please?
1 Reply
Gravatar for mohammad.chowdhury@us.tel.com

Answer by mjc, Apr 7, 2015 4:36 PM

Stack trace was showing nothing but something simmilar to

An error occurred while warming up search page [URL]: class CGLNetwork::NetworkAccessDenied: The login information of server (SERVER NAME) is invalid.

However, the issue has been resolved!

  1. I have restart the server (windows had some update)
  2. Increased readOperationTimeout to 300
  3. rebuild one of the source And it worked!!!

Answering your questions:

  1. I was trying to access search url (search homepage)
  2. We don't use SiteCore
  3. Yes we do use .Net Front-End

I dont know the exact reason why it is happening and I didn't get chance to do the following but could be helpful for someone. http://onlinehelp.coveo.com/en/ces/7.0/administrator/pre-loadingasearchpagetopreventdisplay_delays.htm#Removing

Ask a question