Gravatar for shanidgafur@yahoo.com

Question by sgafur, Jun 18, 2015 4:09 PM

Usage analytics data capture not happening

Hi,

I'm trying to get the usage analytics module working (on premises setup). I've configured the reporting db server and updated the web.config for the front end server to capture the data. I'm also able to see the analytics page (that hopefully proves that I don't haven any issues connecting to the db server from the front end application).

Here's the problem.. I don't see any data getting collected for any queries being made on the front end server. Any ideas on what I might be missing?

Thanks in advance!

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jun 18, 2015 4:28 PM

Are you using Coveo for Sitecore, Coveo JavaScript Search Framework or the Coveo .Net Front-End?

Gravatar for shanidgafur@yahoo.com

Comment by sgafur, Jun 18, 2015 5:39 PM

I'm using the Coveo .net Front End right now. I will need to get this to work via Sitecore as well.

2 Replies
Gravatar for rquirion@coveo.com

Answer by ronald, Jun 19, 2015 9:39 AM

Hi,

Did you configure the analytics settings in the web.config manually or via the Do more menu > Configure Front-End page? Via the configuration page, there is a test button that tries to connect to the SQL database using the provided connection string. Does the test succeed?

Also, the "Integrated Security=SSPI" option in the connection string does not always work. Even if the test button succeeds, the real connection to log actions may fail, because SQL Server may prevent logins from the application pool's identity (e.g. Network Service). In this case, replacing "Integrated Security=SSPI" in the connection string with "User ID=TheUsernameToUseHere;Password=ThePasswordHere" may help.

Seeing the Analytics link in the top bar of the search page does not mean that the connection to the SQL database succeeds.

Finally, when the .NET UI tries to log actions to the SQL database but the connection to it fails (this is done in a background thread), if you perform another action in the search page (e.g. clicking in a facet), an error is normally displayed in red at the top of the search page (if the connected user is an administrator). Do you see an error?

p.s. Note that the JS UI (integrated in Sitecore) cannot log actions to the on-premises analytics module.

Gravatar for rquirion@coveo.com

Comment by ronald, Jun 23, 2015 11:46 AM

Strange indeed. 2 questions: 1) If you connect with SQL Server Management Studio, do you see any records in the Actions table? (This will indicate if it is a connection problem.) 2) When you click on the Analytics link beside Do more, what do you see exactly? Do you see the panels to the left (Interface Filter, Misc Filters, etc.)? (If you see only a "blank" page, this will mean that the problem is at the Silverlight browser plugin level. You could try from another browser.)

Gravatar for shanidgafur@yahoo.com

Comment by sgafur, Jun 23, 2015 1:27 PM

  1. When I connect to SQL Server, I see that all the tables (including ACTIONS) is empty.
  2. When I go to the analytics page, I do see all the panels. Everything just happens to be blank within those panels.
Gravatar for cbilodeau@coveo.com

Comment by christian, Jul 1, 2015 12:56 PM

In order to help the investigation, getting the analytics logs would help to get us in the right direction.

The following link explain how to enable the logs: https://onlinehelp.coveo.com/en/ces/7.0/administrator/loggingusageanalyticsmoduleerrors.htm

Gravatar for shanidgafur@yahoo.com

Answer by sgafur, Jun 19, 2015 9:41 PM

Hi,

I did use a username/password in the connection string instead of the SSPI option. I tested using the Configure Front End page, and it was successful. I have not seen any errors on the search page at all.

Strange, huh?

Ask a question