Gravatar for diego.moretto@xcentium.com

Question by Diego, Jul 19, 2015 12:09 AM

Getting error while indexing

Hello

I installed coveo for sitecore on a sitecore 7.5 but whenever I try to index I get the error bellow.

Versions:

Sitecore.NET 7.5 (rev. 141003)

CES: 7.0 7433

Search API: 8.0.457

Coveo for sitecore: 75 3.0 1081

The diagnostics page show that all services are up and running.

Any ideas on what could be wrong here?

thanks

Job started: IndexUpdateIndexName=sitecoremasterindex|#Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Precondition failed: The parameter 'pParameterValue' must not be an empty string Parameter name: pParameterValue

Server stack trace: at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter) at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

1 Reply
Gravatar for slangevin@coveo.com

Answer by Simon, Jul 20, 2015 6:22 AM

The error is pretty general, but one thing I see is that your Coveo Back-End (Coveo Enterprise Search) is outdated compared to your Coveo for Sitecore. So simply upgrade your Coveo back end instance:

https://developers.coveo.com/pages/releaseview.action?pageId=23233408

Cheers,
Simon

Gravatar for vlambert@coveo.com

Comment by vince, Jul 20, 2015 8:12 AM

Simon is right, a change in the Admin Service, delivered with the CES release of June (7711), is required when upgrading Coveo for Sitecore, otherwise creating this particular issue. 7433 is the February release.

Gravatar for diego.moretto@xcentium.com

Comment by Diego, Jul 21, 2015 11:29 AM

Yes this is a version issue :)

Ask a question