Gravatar for

Question by pnvsrinivas, Sep 1, 2015 9:57 AM

Security provider issues, No mapping between account names and security IDs was done ?


Can any one help me to describe the below warning messages:

Message 1#:

9/1/2015 9:49:50 AM | The security provider "Active Directory" has encountered an exception: class CSP::SecurityInvalidUserGroupException: Unable to convert '<Member name="bharshit" type="User" />' into SID. Error message: class CGLWindows::WindowsInvalidUserGroupException: (bharshit): LookupAccountNameW(bharshit) failed: No mapping between account names and security IDs was done. [0x00000534] | LookupAccountNameW( , bharshit) failed: No mapping between account names and security IDs was done. [0x00000534].

Message 2#

9/1/2015 9:51:23 AM | Error while expanding group n/a (class Merlin::SecurityProviderOnErrorException: Security Provider "Teamcenter KM" failed to start: Unable to get the Blade description for Security Provider "Teamcenter KM": class CGLNetwork::PacketChannel::CannotOpenChannelException: Unable to connect to pipe \\.\pipe\99faa8c9-2c43-4341-910d-dbb457067bb3 [WaitNamedPipe error]. (The semaphore timeout period has expired. [0x00000079]))

Srinivas P N V.

1 Reply
Gravatar for

Answer by gdenhez, Sep 1, 2015 1:24 PM


For message 1#: It's an error of the security provider Active directory. In order to resolve an entity, the provider calls the LookupAccountName function from the Windows API (see ) and it's failing for user "bharshit" with error code 0x00000534.

For message 2#: The security provider named "Teamcenter KM" didn't start because of a timeout. Because of that, the provider is in error. It's probably because a dll is missing for that provider. You can check if there is more info in the event viewer logs.



Gravatar for

Comment by pnvsrinivas, Sep 2, 2015 3:26 AM

Hi Mr. gdenhez,

Thank you for your response.

Can you please suggest me a solution for the Message 1# ?

Srinivas PNV

Gravatar for

Comment by Simon, Sep 20, 2016 11:53 AM

A bit late on this one. A fix was made for the exact same error in March 2016. Have you tried upgrading?

Ask a question