Gravatar for

Question by Diego, Oct 26, 2015 3:37 PM

Coveo rest endpoint error

Hi folks

I'm having an issue with the coveo rest endpoint. I installed coveo for sitecore october 2015 versions(I upgraded the CES and search api as well) and when I open http:/hostname/coveo/rest

I get:

{"statusCode":500,"message":"Call returned SOAP fault: class CES::SearchServerException: No user has been provided for the search request.","type":"ServerReturnedSoapFaultException","executionReport":{"type":"RootReport","description":"","childs":[{"type":"QueryPipelineReport","description":"Resolve pipeline","duration":0,"result":"None","childs":[]},{"type":"QueryPipelineReport","description":"Resolve identities","duration":0,"result":"ArrayBuffer(UserId(sitecore\admin,Sitecore Security Provider for,User,None,None))","childs":[]}]},"results":[]}

I have rebuilt the indexes but that didn´t work. I deleted and readded a security provider for my instance but that still didn´t work after rebuilding.

I've tried theses likes but the values from my configs seem to be right from my environment:

anything I'm missing here?


1 Reply
Gravatar for

Answer by Jean-François L'Heureux, Oct 26, 2015 10:13 PM

  1. Are you calling the Coveo Search API directly (localhost:8080/rest/search) or you go through the Coveo for Sitecore REST endpoint proxy (/coveo/rest) for your queries. You need to pass by the proxy for the logged-in Sitecore user to be added to the search requests.
  2. Do you have allowImpersonate: true in the application of the config.yml file of your Coveo Search API installation? It is needed for the Coveo Search API to impersonate the logged-in user.
  3. Do your indexing and queries are made to the same CES index? You can check that in the CES console for that server. You should see the indexed items when you are indexing and the queries when you are querying. I suspect a server configuration mismatch here.
Gravatar for

Comment by Diego, Oct 27, 2015 8:50 AM

  1. I'm accessing /coveo/rest to check what the error is. The tags on the provider are http://localhost/AdminService https://localhost:52810/7.0/CoveoSearchService
  2. allowimpersonate = true
  3. this is a local dev environment where sitecore and coveo services run on the same windows instance.


Gravatar for

Comment by Jean-François L'Heureux, Oct 27, 2015 11:15 AM

This seems ok.

New questions:

  1. In this CES index, do you have a security provider named "Sitecore Security Provider for"?
  2. Is the server URL of that security provider correctly configured to the local Sitecore instance? This URL is used to expand the Sitecore security roles.
Gravatar for

Comment by Diego, Oct 27, 2015 11:20 AM

yes to both questions

Gravatar for

Comment by Jean-François L'Heureux, Oct 27, 2015 9:23 PM

I'm out of options now. You should create a new support case for that issue. The support team will be able to troubleshoot this better than me over this site. Be sure to send them your config files for Coveo for Sitecore and the Coveo Search API and also a copy of the ShowConfig.aspx page.

Thank you.

Ask a question