Gravatar for artem@brainjocks.com

Question by artem, Jan 19, 2016 5:41 AM

Empty Search JSON result

Inputs: Sitecore 8 Update 5. Coveo Enterprice Search 7.0 x64 Build 7814.0. Coveo for sitecore: Sitecore Integration 3.0 September 2015 Release. Free edition for dev purposes. CES and Sitecore are on different servers.;

Problem: Always empty result on search.

At the beginning I had an idea that something wrong with my coveoProcessRestJsonResponse or coveoProcessParsedRestResponse. But no errors in logs. After some more invstigation, I figured out, that the problem is on CES server.

I opened CES Log -> Query

**Severity:** NORMAL
**Date:** 05:26:28 PM    
**User:** extranet\Anonymous [Sitecore Security Provider for ARTEMS-TABLET-myprojectsite]    
**IP address:** 127.0.0.1    
**Query:** @uri 
**Advanced query:** @syssource==("Coveo_web_index - DEV") NOT @ftemplateid62093==(adb6ca4f-03ef-4f47-b9ac-9ce2ba53ff97,fe5dd826-48c6-436d-b87a-7c4210c7413b)
**Collections:**
**Corrected:** No
**First Result:** 0
**Requested results:** 10
**Returned results:** 0
**Filtered:** No
**Sort by:** Relevance
**Status:** NoResults
**Error code:** SUCCESS    
**Index:** 
**Mirror:** Default
**Distributed:** No
**Super User Access:**
**On behalf:**
**Full access from index browser:** n
**Disjunctive query:**
**Hidden query:** n
**Parent field:**
**Child field:**
**Background query:** n
**Custom filter field:**    
**Custom filter range:** 5

Also:

  • We don't have any restrictions in Sitecore. So all indexed documents should be accessible for Anonymous user
  • If I run @syssource==("Coveowebindex - DEV") NOT @ftemplateid62093==(adb6ca4f-03ef-4f47-b9ac-9ce2ba53ff97,fe5dd826-48c6-436d-b87a-7c4210c7413b) @uri within UI of CES server I got all documents which were indexed. So index works correct.
1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Jan 19, 2016 7:07 AM

Hi Artem,

Thank you for the level of details in your question.

I would guess a security provider problem. Check the Sitecore security provider in CES. Check its "Server URL" parameter. The URL sould be the one of your Sitecore instance. Try accessing this URL from a browser on your CES server.

If the URL seems right but unreachable, this is a firewall issue.

If the URL seems local to the Sitecore server try specifying the public URL of Sitecore in the <ServerUrl> node of your coveo.searchprovider.config file.

After fixing the URL, a re-index of at least one Sitecore item will be necessary to synchronise the configuration. Then, you'll need to force a refresh of the CES security cache from the Overview > Details section of the CES administration tool to make the expansion of the cached Sitecore groups and users inside CES.

I hope this helps.

Jeff

Gravatar for artem@brainjocks.com

Comment by artem, Jan 19, 2016 8:30 AM

I can't specify the public URL of Sitecore instance which can be reachable outside. My url looks like "http://myprojectsite/" - it's specified in the Sitecore Security Provider within CES. Could unreachable url be the root of the problem? In that case, do you have any workaround for developers?

CES7 installed in Amazon. Sitecore instance setup on devs local computers. All devs have the same Sitecore instance URL (leterally) which bound to 127.0.0.1

Ask a question