Gravatar for rajni@medinfo.net

Question by rakum, Mar 4, 2016 8:27 AM

Issues with rebuild of coveo index in sitecore

I am testing out coveo for sitecore. I am working on sitecore 7.2 an dhave installed Coveo CES from https://developers.coveo.com/pages/releaseview.action?pageId=26444405

I have installed package Coveo for Sitecore 72 3.0 (1226). The problem is that i am not able to build the index. I get following error when i click on rebuild:

Coveo_web_index|#Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Precondition failed: The parameter 'p_ParameterValue' must not be an empty string
Parameter name: p_ParameterValue

How can i fix this error?

Thanks in advance!

regards

Rajni

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Mar 4, 2016 9:59 AM

Hi Rajni,

The installation documentation link you followed is for the September 2015 release of Coveo for Sitecore. You also say that you installed the January 2016 release of Coveo for Sitecore (1226).

I think you installed the August 2015 release of Coveo Enterprise Search 7.0 and the September 2015 release of the Coveo Search API. Due to your older Coveo Enterprise Search and newer Coveo for Sitecore, there are a few API calls missing.

Coveo Enterprise Search, Coveo Search API and Coveo for Sitecore are products that evolve together. When installing them, you should install the monthly versions that are matching.

I recommend you to upgrade your Coveo Enterprise Search and Coveo Search API products to the versions 7.0.8047 and 8.0.893 respectively as documented in the Coveo for Sitecore download page: https://developers.coveo.com/display/SitecoreV3/Downloads

Then, rebuild your indexes and everything should work as expected.

I hope this helps,

Jeff

Ask a question