Gravatar for chris.williams@readwatchcreate.com

Question by chris williams, May 9, 2016 8:44 PM

coveo for sitecore only indexes fallback language but not other languages

For some reason in the index, I only see the items for the fallback language in our case /na/ in the index and not the other lanaguages. Is there a setting I need to add so it will index all the other languages from Sitecore?

Gravatar for chris.williams@readwatchcreate.com

Comment by chris williams, May 10, 2016 11:01 AM

Ok partially solved this one. Oddly the presentation details on final was right but not for shared on standard values. The page in sitecore was inheriting the shared. I made sure shared and final have layout set right and now coveo is indexing. I guess if the pages look exactly the same then it only appears in first language.

Now it is indexing the item per language but for both /na/ and /de/ items the url still says /na/ for clickable and printable url in the index when I click on details.

1 Reply
Gravatar for sbelzile@coveo.com

Answer by Sébastien Belzile, May 10, 2016 8:14 AM

What is your Sitecore + C4SC version?

With Sitecore 8.1, everything should be fine with language fallback: it is integrated in Sitecore's Search Provider API. Coveo simply takes what Sitecore feeds it.

With versions prior to Sitecore 8.1, the module has not been tested much internally on our side.

Gravatar for chris.williams@readwatchcreate.com

Comment by chris williams, May 10, 2016 4:23 PM

Current Coveo for Sitecore version: 3.0.1226.0 Current Sitecore version: 8.1.151207

The rest of the details of the item in coveo index browser is correct it is just the clickable uri and printable uri that have the /na/ in it.

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, May 11, 2016 1:20 PM

I'm not able to reproduce your problem.

  1. I have enabled language fallback in Sitecore's configuration file.

  2. French fallbacks on english.

  3. I added: true in my index configuration.

My URLs are OK in my index, same on my search page. Same thing if I use language fallback on a field level.

Do you have a different configuration? Any special modules? A custom link provider?

Gravatar for chris.williams@readwatchcreate.com

Comment by chris williams, May 20, 2016 9:39 AM

Is this the right place to put hte key?

      <index id="Coveo_web_index" type="Coveo.SearchProvider.ProviderIndex, Coveo.SearchProvider">
        <param desc="p_Name">$(id)</param>
        <configuration ref="coveo/defaultIndexConfiguration" />
        <enableitemlanguagefallback>true</enableitemlanguagefallback>
        <locations hint="list:AddCrawler">
          <crawler type="Coveo.SearchProvider.CoveoItemCrawler, Coveo.SearchProviderBase">
            <Database>web</Database>
            <Root>/sitecore</Root>
            <StopOnError>true</StopOnError>
          </crawler>
        </locations>
        <strategies hint="list:AddStrategy">
          <strategy type="Sitecore.ContentSearch.Maintenance.Strategies.OnPublishEndAsynchronousStrategy, Sitecore.ContentSearch">
            <param desc="database">web</param>
            <CheckForThreshold>true</CheckForThreshold>
          </strategy>
        </strategies>
        <propertyStore type="Sitecore.ContentSearch.Maintenance.IndexDatabasePropertyStore, Sitecore.ContentSearch">
          <Key>$(id)</Key>
          <Database>core</Database>
        </propertyStore>
      </index>
Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, May 20, 2016 9:47 AM

Yes: https://doc.sitecore.net/sitecoreexperienceplatform/settingupmaintaining/languagefallback/settingup/configurelanguage_fallback

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, May 20, 2016 2:16 PM

I think the XML node case is important though: <enableItemLanguageFallback>

Ask a question