Gravatar for

Question by seinarsson, Jan 30, 2017 1:54 PM

Sitecore to Coveo, RabbitMQ authentication error

When trying to rebuild my Coveo indexes in Sitecore, I'm getting the following error…

I've created a user "sitecoreRabbitMQ" in the RabbitMQ admin page (localhost:15672/#/users), then in Sitecore -> Control Panel -> Coveo Search -> Configuration I set this user/password for the Indexing Queue Connection.

I checked the Coveo.SearchProvider.config, and the QueueUsername was updated to the "sitecoreRabbitMQ" user.

What else could be causing an authentication error with RabbitMQ?


Gravatar for

Comment by seinarsson, Jan 30, 2017 2:21 PM

I've also tried just using the default guest/guest user. Same error.

Gravatar for

Comment by Jean-François L'Heureux, Jan 31, 2017 10:03 AM

A firewall can be the cause of the communication problem between your Sitecore and CES servers. Have you checked it?

Gravatar for

Comment by seinarsson, Feb 1, 2017 9:49 AM

The CM and CES are on the same server, and the ports are already open to let the CD server in. I can access the RabbitMQ backend from the CD server through the browser.

0 Reply
Ask a question