Gravatar for wvuong@captechconsulting.com

Question by wvuong, Mar 28, 2017 8:44 PM

RabbitMQ not acknowledging

We are experiencing issues with our RabbitMQ queues correctly processing all messages.

We have queues that have a large number of messages in the ready state, 1000 messages in the unacked state and not actively acknowledging them.

I have tried deleting the queues and disabling/enabling live monitoring to reset everything. The queues will work for a bit before the same issue arises. I then checked the CES console while running a re-index after a reset a noticed a large of number of the following error

Exception while processing an item:  -> The request failed with HTTP status 417: Expectation Failed.
Uri to ignore for deletion : localhost/Coveo_pubweb_index - test/Document:sitecore%3a%2f%2fdatabase%2fpubweb%2fItemId%2fsitecore-id%2fLanguage%2fen%2fVersion%2f1

Not all items indexed will result in this error, but I'm not sure what could be causing this.

Edit: It looks like only images are causing this error

Using Fiddler I was able to pull some more information. It is making a post request

POST //sitecore%20modules/Web/Coveo/WebService/SitecoreWebService.asmx HTTP/1.1

which results in the 417

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, Mar 29, 2017 2:37 PM

Have you set your `serverUrl` tag in your `Coveo.SearchProvider.config` file, or better, added it from a patch file configuration?

It is located in `sitecore` > `coveo` > `defaultIndexConfiguration` > `serverUrl`.

The URI used to fetch the binary data should prepend the `serverUrl` before `/sitecore%20modules`, so I suspect your node might be empty.

1 Reply
Gravatar for bgarneau@coveo.com

Answer by BGarneau, Apr 3, 2017 6:10 PM

William confirmed that changing the value for serverUrl solved the issue.

Ask a question