Gravatar for

Question by vlovlo, Mar 2, 2018 6:01 PM

Facet based on new Salesforce custom field not showing up

I am in the free trial version for Salesforce. I created a new custom text field, and want to use it as a facet. I tried both the UI and the code, but cannot get the new facet to show up. It worked for a short minute yesterday evening, and now it's gone.

I appreciate quick answer, I am building a time-sensitive POC. Thanks

1 Reply
Gravatar for

Answer by amoreau, Mar 2, 2018 6:17 PM

If you are using the Free edition, using newly created custom fields usually requires a bit of time.

You can find more detailed information about this here:

Let me know if you have more questions.


Gravatar for

Comment by vlovlo, Mar 2, 2018 6:20 PM

Thank you @amoreau

! I also found a way to check if the schema is available:

  1. Wait from 15 minutes to 6 hours after the creation of your custom field. During that time, you should not query using Coveo so the old schema can timeout.
  2. In a Coveo search page, search for your field.


    You created a new custom field called MyCustomField. Because it is a custom field, its Salesforce API name is MyCustomFieldc.

    In a Coveo search page, in the query box, you enter @sfmycustomfieldc, which is not expected to return any results.


    If, at this point, your query returns results that include your new field, then it was already added to the Coveo Search API schema.

  3. Wait up to a minute, giving the Coveo Search API time to update the schema.
  4. Perform the search again. You should now have results for your field.

Gravatar for

Comment by laurel.jones, Mar 29, 2018 9:12 PM

@amoreau, I have this issue and the field is still not available for the facet. It's been DAYS and it's saying that field is not available for facet. Any thoughts?

Ask a question