Gravatar for abhinav.s.singh@avanade.com

Question by abhinav, Nov 23, 2018 2:19 PM

clickuri is pointing to json value

We have integrated Coveo Hive UI here but upon clicking it's redirecting to json and into json clickuri value is correct but on front end site my url is like this hostname/en/coveo/rest/sitecore/content/home/relativeurl

Gravatar for hsantos@coveo.com

Comment by Hugo Santos, Nov 23, 2018 2:27 PM

Do you have a custom LinkProvider? More often than not it is responsible for those weird clickUrls.

Try to add a few breakpoints on it and rebuild your indexes to make sure you understand what's going on.

Gravatar for abhinav.s.singh@avanade.com

Comment by abhinav, Nov 25, 2018 6:39 AM

Yes, we have custom LinkProvider but all links are pointing to sitecore item but only into Coveo Search resultlist control it's pointing to json while clickuri is proper if i look into content browser from coveo admin console.

1 Reply
Gravatar for abhinav.s.singh@avanade.com

Answer by abhinav, Nov 26, 2018 10:52 AM

we got the root cause and fixed it.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Nov 26, 2018 11:15 AM

Do you mind explaining what was the cause and the solution please? This will be helpful to other people who might have the same problem in the future.

Thanks

Gravatar for abhinav.s.singh@avanade.com

Comment by abhinav, Nov 27, 2018 4:50 AM

Below setting was the root cause what is defined into Coveo.search.provider.config

<site patch:before="*[1]" name="coveorest" virtualFolder="/coveo/rest" physicalFolder="/coveo/rest" enableTracking="false" database="web" domain="extranet" />

Please comment out above settings, would resolve the issue.

Ask a question