Gravatar for corrac@paragon-inc.com

Question by Cris Corra, Jul 1, 2014 10:35 AM

Multi-value fields built from meta header tags are delimited by commas.

In Coveo for Sitecore, the multi-value fields are delimited by semi-colons, but in a regular index source, when building a field from meta tags the values are delimited by commas. Is there a way to specify to use semi-colons vs. commas in the values created from the meta-tags?

-Cris Corra

2 Replies
Gravatar for lbergeron@coveo.com

Answer by Luc Bergeron, Jul 1, 2014 1:22 PM

This is not possible out-of-the-box yet. In the july 2014 release of Coveo for Sitecore (planned to be released later this week), it will be possible to set the separator for the multi-value fields directly from the Coveo.SearchProvider.config file.

In the mean time, the only way I see would be to add a custom processor to the CoveoPostItemProcessingPipeline pipeline. You would then be able to alter the content of the field just before the document is indexed. You can find more information regarding Coveo pipelines on this page: https://developers.coveo.com/display/SC201406/Using+the+Coveo+Pipelines.

Hope this helps

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Jul 1, 2014 1:53 PM

So outside of Sitecore, you can not configure what the delimiter is for multi-value fields either?

Gravatar for lbergeron@coveo.com

Comment by Luc Bergeron, Jul 1, 2014 2:35 PM

In fact, you can configure the multi-value delimiter in CES Administration Tool (Index > Advanced > Multiple Value Fields). It tells CES how to split multi-values. But beware, you can break existing field values if you change the separator (or add new ones).

More information is available on this page: http://onlinehelp.coveo.com/en/ces/7.0/Administrator/modifyingorusingadvancedindex_parameters.htm

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Jul 9, 2014 3:43 PM

This setting is set to a semi-colon. But why is my multi-value field delimited by a comma?

Meta tags field is populated from: http://cl.ly/image/2W3J1r2N0O3E/Windows7VSNET2013.png

Field value in index: http://cl.ly/image/1X0t1a161j2X/Windows7VSNET2013.png

-Cris

Gravatar for lbergeron@coveo.com

Answer by Luc Bergeron, Jul 4, 2014 9:33 AM

You can tell Coveo for Sitecore to use commas instead of semi-columns by adding this element into Coveo.SearchProvider.config. Make sure to add it inside the DefaultIndexConfiguration element.

<MultipleValueSeparator>,</MultipleValueSeparator>

This feature is available in Coveo for Sitecore 3.0.558 an up.

Ask a question