Gravatar for richardbanks@redweb.com

Question by richardbanks, Apr 1, 2019 2:02 PM

coveo for sitecore HTTP Error 401.2 - Unauthorized

Hi, i hope someone can help as im having a lot of issues getting coveo for sitecore to work. Currently i have installed version 82 4.1.732.176 into sitecore 8.2 update 7, however when i visit the diagnostic page i get a Error 401.2 - Unauthorized response You are not authorized to view this page due to invalid authentication headers for both the coveo search endpoint and the Coveo Search Web Service. Everything else is green and ok. Ive checked the application secret in the config.yml and the coveo.searchprovider.rest.custom.config and they match. ive also browsed to http://localhost:8080/rest/search which returns back alot of json some of which i have pasted below. Any ideas?

{
  "totalCount" : 15916,
  "totalCountFiltered" : 15916,
  "duration" : 70,
  "indexDuration" : 10,
  "requestDuration" : 54,
  "searchUid" : "2a846ad8-638c-4b02-8ebd-e36cc50833d3",
  "pipeline" : "default",
  "apiVersion" : 2,
  "triggers" : [ ],
  "termsToHighlight" : { },
  "phrasesToHighlight" : { },
  "queryCorrections" : [ ],
  "groupByResults" : [ ],

i also get the following

Failed to obtain resource located at 'http://local-xxxxxxx.xxxx.network/coveo/rest/'. [BEGIN RESPONSE BODY]

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, Apr 1, 2019 2:53 PM

Have you checked similar questions? See here: support.coveo.com - 401 unauthorized

It looks like there are a couple of causes for this, I would suggest going through previous answers and see if any match what you have.

0 Reply
Ask a question