Gravatar for ashish.shakya@cir2.com

Question by ashakya, Aug 25, 2016 5:10 PM

On Premise Search Token Authentication with sharepoint claims

I'm trying to initialize the On Premise Search token authentication following the steps in the https://developers.coveo.com/display/public/SearchREST/On-Premises+Search+Token+Authentication.

Facing a couple of issues at this point:

  1. The preflight request to the /search/token endpoint fails. I see the following the browser console: OPTIONS https://…./rest/search/token net::ERRCONNECTIONTIMED_OUT I understand that this is a CORS issue and if I set the origin to the domain, it'll work. Is this correct?

  2. Since, I was not getting the token as above, I used postman to get a search token. However, when I try to initialize with the token, it still asks me for the windows credentials. This is because I have set the windowsAuthentication enabled:true in the config.yml. Do I need to keep this if I want to use the SharepointUnderClaims?

Gravatar for mlaporte@coveo.com

Comment by Martin Laporte, Aug 26, 2016 3:48 PM

I don't see a clear link between search tokens and SharePoint claims… In particular, Search Tokens are typically requested from a backend of some sort, so CORS is not an issue.

What are you trying to configure exactly?

Gravatar for ashish.shakya@cir2.com

Comment by ashakya, Aug 26, 2016 4:30 PM

We have non Domain users who log into our web application. The web application needs to send them to a coveo JS UI page to search internal sharepoint sites and give them access to those resources.

I was going through the documentation and it seemed as if the search tokens were the way to do this.

Please forgive me if my understanding is a wrong.

0 Reply
Ask a question